V2EX 首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Sponsored by
二向箔安全
​一对一的线上 web 安全培训服务
咨询微信:twosecurityrefer
Promoted by 二向箔安全
V2EX  ›  Ruby on Rails

初学者请教一个 ruby 使用 leveldb 的问题

  •  
  •   larkifly · 2016-11-29 17:15:47 +08:00 · 870 次点击
    这是一个创建于 383 天前的主题,其中的信息可能已经有所发展或是发生改变。
    背景是:我目前接手别人的代码
    问题:当我在文件加上 require "leveldb" 就开始报错:

    .rvm/gems/ruby-2.3.0/gems/mongo-2.2.4/lib/mongo/protocol/message.rb:97:in `serialize': uninitialized constant BSON::ByteBuffer (NameError)

    当我去掉 require "leveldb",就正常了。
    请问这个问题怎么修复了?

    ps :我已经尝试在 Gemfile 里加 gem bson ,没有用
    1 回复  |  直到 2016-11-30 05:18:27 +08:00
        1
    msg7086   2016-11-30 05:18:27 +08:00
    Did you mean: require 'bson'?
    DigitalOcean
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   2056 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.0 · 33ms · UTC 01:07 · PVG 09:07 · LAX 17:07 · JFK 20:07
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1