首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  macOS

最新款 Mac 电脑是否能安装更早的系统?

  •  
  •   islujw · 28 天前 · 2972 次点击

    由于 Server.app 在 Mojave 被砍掉大部分功能的原因,我需要持续使用 High Sierra 系统,而不使用 Mojave。

    如果购买最新款 Mac 电脑(如 Mac mini、MacBook Pro 等),出厂自带的都是 Mojave 系统了。是否可以安装成 High Sierra 或更早期的系统呢?

    我在 Apple 支持站点找到这个: https://support.apple.com/zh-cn/HT201372 借助 U 盘创建可引导的 macOS 安装器。但不知道旧系统是否能在新设备上正常运行。

    此外,假设旧系统可以在新设备上运行,更早的系统如 OS X 10.8 Mountain Lion 呢: https://www.apple.com/cn/shop/product/D6377CH/A 如果可以安装,还真想体验一下这个支持 Retina 的拟物设计系统。

    第 1 条附言  ·  27 天前
    另一个方法,是提供一个类似 Server.app 的简单易用的服务器管理程序,但似乎 Mac 平台还没有能与之比肩的产品……
    第 2 条附言  ·  27 天前
    已从 Apple 支持站点确认:Mac 随附的 macOS 版本是与该 Mac 兼容的最低版本。
    《使用 Mac 随附的 Mac 操作系统或兼容的更新版本》 https://support.apple.com/zh-cn/HT201686
    40 回复  |  直到 2019-05-25 23:42:09 +08:00
        1
    minamike   28 天前 via iPhone
    没有驱动吧
    或许虚拟机可以试试
        2
    Sylv   28 天前 via iPhone
    据我所知不能,旧系统不带新机型的驱动。
        3
    dingdangnao   28 天前
    不可以
        4
    q397064399   28 天前
    没有驱动,老系统怎么兼容还未上市的硬件呢 doge
        5
    DEANHZED   28 天前 via iPhone
    黑苹果?/滑稽
        6
    islujw   28 天前
    @minamike @Sylv @dingdangnao @q397064399 会不会在恢复模式下连接 Wi-Fi 后,自动开始获取新的驱动呢?
        7
    minamike   28 天前 via iPhone
    @islujw 你是不是想多了.jpg
        8
    dingdangnao   28 天前
    @islujw 不会
        10
    islujw   28 天前
    @dingdangnao 这个链接只是介绍了机器本身的恢复模式。我上面提到的恢复模式,可能没说清楚,是指通过 U 盘创建的引导安装环境。
        11
    islujw   28 天前
    @minamike @Sylv @dingdangnao @q397064399 但在升级到 High Sierra 的文章( https://support.apple.com/zh-cn/HT208969 )里,提到支持的机型时,说的是“或更新机型”,那应该是包含了 2019 年的最新机型?
        12
    Satelli   28 天前
    @islujw macOS 内置设备的驱动是随系统分发的。旧版本 macOS 不会带新设备的驱动。再者,驱动是一方面,旧版本 macOS 内核不支持新设备的 CPU,要么你 spoof CPU ID 强行装回去,要么自己给内核打 patch 吧。
        13
    specialperson   28 天前
    我 2018 mbp 13 刚刚出来的时候买的,系统版本是 10.13.4。
    所以 High Sierra 在 18 款 MBP13 是可以用的
        14
    islujw   28 天前
    @Satelli 如果确定不能支持的话,上面第 11 层提到的技术支持文档岂不是写得太不严谨了。
        15
    carlclone   28 天前
    这个要你自己试一下的 , 比如有的老旧驱动在 10.14 , 苹果的做法是直接删去 , 我从 10.13 复制 kext 过去重建缓存就可以用了 , 你可以参考一下从 10.14 的驱动复制过去老系统看看能不能用
        16
    q397064399   28 天前
    给老的操作系统 添加新的硬件驱动 怎么算,都不划算吧... 这又不是 windows 他们有很多企业用户 一套驱动要从 98 兼容到 win10
        17
    c0878   28 天前
    看设备发售的时候第一批出厂带的是什么版本那就是能安装的最早版本
        18
    joyhub2140   28 天前
    别说 Mac 的系统了,你拿旧内核的 linux 桌面装到新硬件,都一大堆驱动问题。
        19
    islujw   28 天前
    @carlclone kext 文件本身就是驱动吗?还是说复制后会有一个下载的过程呢?我打算去 Apple 店里获取一下文件。
        20
    kouryu   28 天前 via iPhone
    买到手自带系统不算,
    要看这个型号最初发布的时候自带版本,不能低于这个版本。
    我今年买的 rmbp15 到手系统 10.14 ,照样可以 u 盘安装 10.13.6
        21
    zetary   28 天前
    可以的, 之前为了外接 n 卡就装了一个出厂的版本
        22
    orqzsf1   28 天前
    可以考虑黑苹果。。
        23
    islujw   27 天前
    @kouryu 是的,这样问我觉得最为严谨。
        24
    islujw   27 天前
    @kouryu “不能低于最初发布时自带的版本” 是如何得出的,你是否尝试过?
        25
    kouryu   27 天前 via iPhone
    @islujw 只要该型号发布的时候系统是什么版本,就可以用 u 盘安装这个版本。更之前的版本不可以安装。

    我手头的这款,rmbp15 虽然生产日期是今年 3 月份,但是这个型号是去年就可以购买并且出厂预装的 10.13 ,那么就可以顺利滚回 10.13 。
        26
    nyanyh   27 天前
    2018 出的时候还是 10.13.6,虽然出厂带的是 10.13.6,但是这个版本和 MAS 里下的 10.13.6 不一样,用 MAS 的装了启动不了,当时抹盘重装之后就只能网络还原。
    所以我认为是不能装低于出厂版本的 OS 的
        27
    nyanyh   27 天前
    @nyanyh #26 说错了,是 10.12.5
        28
    ETiV   27 天前 via iPhone
    同 26、27

    对于 2018 款 mbp
    可以网络还原到出厂的系统版本(开机时按某个组合键),不能通过 U 盘安装,装不上

    新 mbp 很搞,默认不允许外置磁盘启动,需要解锁。解锁需要已安装系统的管理员账号密码。
    所以千万不要在 mbp2018 上用 U 盘启动、格盘安装( Mac App Store 下回来的) HighSierra

    Mac mini、MacBook Air 是在 Mojave 正式 release 之后出来的系统? 那就不能装老版本的系统了
        29
    kouryu   27 天前 via iPhone
    @nyanyh
    @ETiV
    2018 的 touch bar 的 rmbp 有点特殊,安装的并不是 mas 里的版本。可以通过脚本下载到对应的系统,安装。这个我亲自实践过。10.13 肯定是可以安装。
        30
    leopku   27 天前
    其实我挺好奇 LZ 需要哪些 Server.app 里的功能?
        31
    islujw   27 天前
    @kouryu 是因为 T2 芯片的关系吗?
    @ETiV 你说到“需要解锁,解锁需要已安装系统的管理员账号密码”,这个是开启了 FileVault 之后的效果吗?那如果已安装系统被抹掉了呢?
        32
    islujw   27 天前
    @leopku 最主要使用网站的配置,认为比较简单好用。其他的也偶尔会用到,除了使用也有研究意义。
        33
    ETiV   27 天前 via iPhone
    @islujw 跟开不开 FileVault 无关,这应该是 T2 芯片的特性

    如果已经抹掉了硬盘,则需要从 U 盘安装一个可用的,并登录进去设置好管理员用户、密码,再重启、重装。

    相当折腾…我当时折腾的时候,Mojave 还在 beta,但可以 U 盘安装,这是唯一的办法
        34
    mmtromsb456   27 天前 via iPhone
    首先在 macOS 中 /System/Library/Extensions /Library/Extensions 基本包含了绝大部分用到的 kext (这个就是 macOS 中驱动的代名词(内核拓展模块)
    其次一台设备可以安装的最早的系统版本为出厂自带版本(最好是+0.1 ).因为只有这两种情况下系统中才有新设备的驱动(包括但不限于 CPU/GPU/特殊设备比如 Touch ID 的驱动).系统中拥有相关的驱动才可以进行识别并且正确驱动.
    综上所述..要用 highseirra 的话
        35
    mmtromsb456   27 天前 via iPhone
    @mmtromsb456 不小心点到添加回复了 Orz
    综上所述,要使用 macOS High Seirra 的话请直接使用 10.13.6 的版本进行制作 USB 引导安装盘安装(请记得设置 T2 的相关设置)
        36
    mmtromsb456   27 天前 via iPhone
    @islujw 复制相关 KEXT 并添加到相关记录是不太可行并且没有意义的.不太可行是因为复制了 kext 需要重建相关的缓存.一个不小心重建出错就 gg 了.没有意义是因为实际上只要安装系统是相同的驱动就是相同的.设备应用的部分都是系统拥有部分的子集.
    以上言论仅针对 Apple,Inc 制作的设备.黑苹果由于可能会在 SLE/LE 等不同路径引入特定驱动不在此言论覆盖范围内.
        37
    islujw   27 天前
    @mmtromsb456 谢谢你的详尽解答。我大概率会买一个 Mac mini 来装 High Sierra,至于笔记本,可能有一天会换,但会使用 Mojave,而 Mac mini 就当作家中服务器的方式,来使用 Server.app 。
    Mac mini 最新款本身的升级,应该只有 CPU 等等的常规升级,而没有 T2 吧?
        38
    mmtromsb456   27 天前 via iPhone
        39
    leopku   26 天前
    @islujw 「网站配置」为啥不用 Linux 呢,周边成熟,资料更多
        40
    islujw   23 天前
    @leopku 倒不是因为实现,Mojave 也可以网站配置。主要是欣赏 Server 的设计理念,以及体现在 UI 上的简易性,这对频繁配置时的效率提升也有所帮助,因此希望能保持下去。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3871 人在线   最高记录 5043   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 20ms · UTC 09:19 · PVG 17:19 · LAX 02:19 · JFK 05:19
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1