首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
宝塔
V2EX  ›  iOS

问 iOS 工程师们一个问题,大家会用最新的 Xcode7.0 来开发嘛?

  •  
  •   heronlyj · 2015-09-11 12:12:32 +08:00 · 3059 次点击
    这是一个创建于 1533 天前的主题,其中的信息可能已经有所发展或是发生改变。

    大家会用最新的 Xcode 7.0 来开发嘛?

    请问:利与弊~~~~
    
    公司项目是 Swift 写的,如果升级成 Xcode7 的话 Swift 语法会有所改变(2.0 ),对大家的影响会有哪些~
    
    20 回复  |  直到 2015-09-11 23:48:46 +08:00
        1
    cielpy   2015-09-11 12:16:21 +08:00
    会,适配 9.0 ,应用新的 API ,新的 SDK ,迟早要换,不如早换。
        2
    YYYeung   2015-09-11 12:45:52 +08:00
    用来写入证书的东西,省去购买开发者账号的钱,然后回到 Xcode6 继续写代码
        3
    pH   2015-09-11 13:06:27 +08:00
    @cielpy 适配 9 那么运行在以前系统的机器运行此程序怎么办?
        4
    heronlyj   2015-09-11 13:06:46 +08:00
    @cielpy 很多第三方库会有影响吧
        5
    heronlyj   2015-09-11 13:07:41 +08:00
    @YYYeung 这确实是一个很好的点,对准备学习 iOS 开发的人来说,不用先买一个开发者账户就能部署应用了
        6
    racechao   2015-09-11 13:09:10 +08:00
    用啊,语法异常的地方改成 2.0 的语法不就好了
        7
    dorentus   2015-09-11 13:19:34 +08:00   ♥ 1
    会。

    并且我要把我们目前 Swift 1.2 的项目迁移到 Swift 2.0 ,同时 drop 对 iOS 7 的支持。
        8
    nathanw   2015-09-11 13:56:20 +08:00
    最后上架打包 还是得用 Xcode7 的。
        9
    bullettrain1433   2015-09-11 14:01:28 +08:00
    肯定会啊,苹果的东西不用想,直接升级
        10
    wezzard   2015-09-11 14:41:26 +08:00
    2.0 的語法相對於 1.2 來說簡直太棒了
        11
    X0pp0X   2015-09-11 14:50:44 +08:00
    刚用上 7 就报一堆 BUG 而且都是很奇怪的 BUG 好郁闷
        12
    botasky   2015-09-11 14:53:56 +08:00 via Android
    刚使用就踩进了 TextView 的 bug
        13
    mornlight   2015-09-11 14:55:17 +08:00
    现在 Xcode 7 没有出正式版,追求稳定的项目是不需要用的。出正式版之后通常是不想用都不行,适配 iOS 9 必须用新版的来做啊。

    更何况, Xcode 7 终于自己带模糊匹配功能了,感人。
        14
    DingSoung   2015-09-11 15:22:22 +08:00
    原来不止我也在公司项目中用 Swift ,感觉找到部落了 XD
        15
    bestkayle   2015-09-11 19:09:40 +08:00
    这么多用 swift 的公司嘛,
        16
    arkilis   2015-09-11 19:28:34 +08:00
    @YYYeung 省去开发者账号的费用?
        17
    YYYeung   2015-09-11 22:11:23 +08:00
    @arkilis 对于还在学习路上的同学来说, Xcode7 可以让我们免费在真机调试
        18
    hoogle   2015-09-11 22:18:44 +08:00 via iPhone
    @mornlight 感觉并没有的? 没 Fuzzy 已经是无法写代码的状态
        19
    mornlight   2015-09-11 23:18:35 +08:00
        20
    hoogle   2015-09-11 23:48:46 +08:00 via iPhone
    @mornlight 赞, 试一下
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2663 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 23ms · UTC 11:03 · PVG 19:03 · LAX 03:03 · JFK 06:03
    ♥ Do have faith in what you're doing.