首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  互联网

外网无法访问 NAS

  •  
  •   iCasture · 2016-08-05 23:39:22 +08:00 · 962 次点击
    这是一个创建于 1173 天前的主题,其中的信息可能已经有所发展或是发生改变。

    之前被电信扔到了内网里,今天打 10000 投诉,给了我个公网 IP 。路由器显示 WAN 口 IP 地址是 182.40.XXX.XXX ;万网获取到的 IP 有俩,一个是 182.40.XXX.XXX ,一个是 10.194.102.4 。

    但是现在我连着家里 WiFi 的时候,用 182.40.XXX.XXX:8080 能访问到路由器的管理页面,但是用 4G 完全打不开。 WiFi 能 ping 通 182.40.XXX.XXX , 4G 不行。

    NAS 在路由上做了端口转发, 7777 转发到 NAS 的 8080 。但是不管用 WiFi 还是 4G ,通过 182.40.XXX.XXX:7777 完全无法访问。

    这是为啥?我设置的问题?

    5 回复  |  直到 2016-08-06 18:46:25 +08:00
        1
    SNOOPY963   2016-08-06 00:21:02 +08:00 via iPhone
    运营商禁了 8080 ,建议改用 https 的 8443
    或者在路由器上把 8080 改为附近端口如 8078

    另,路由器默认是不让从 WAN ping ,建议开启重试。

    NAS 的问题,先看局域网 IP:8080 是否正常
        2
    iCasture   2016-08-06 17:05:25 +08:00
    @SNOOPY963 确实是在路由禁止了 WAN ping ,之前没发现, thanks ~

    NAS 使用 5000 (HTTP), 5001 (HTTPS) 端口,现在 4G 下能使用 182.40.XXX.XXX:5000 访问,但是连着 WiFi 却打不开。内网访问正常。这是为什么?
        3
    SNOOPY963   2016-08-06 17:19:34 +08:00
    @iCasture 打不开的提示是? 会不会存在说其它的代理设置导致这样的问题?
        4
    iCasture   2016-08-06 18:07:32 +08:00
    @SNOOPY963 取消了代理设置,问题依旧。打开的时候一直是正在加载的空白页面,许久许久一直这样
        5
    SNOOPY963   2016-08-06 18:46:25 +08:00
    @iCasture 查看路由器日志吧。。。想不到其它原因了,等更懂的来答。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3799 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 21ms · UTC 10:04 · PVG 18:04 · LAX 03:04 · JFK 06:04
    ♥ Do have faith in what you're doing.