首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
V2EX  ›  问与答

求助,一个关于 Java 的语言设置问题。

  •  
  •   Luckyray · 2017-04-11 16:16:54 +08:00 · 1479 次点击
    这是一个创建于 945 天前的主题,其中的信息可能已经有所发展或是发生改变。

    运行 Tomcat 的时候, Messages Build 出现了错误提示: ![]( https://rayforgit.github.io/2017/03/17/遇到的小问题合集 /s2.png)
    然后中文因为字体的关系不能显示,这里由于实在是喜欢这个字体,不想换成很丑的中文,而且 JVM 的错误提示还是英文搜索起来比较方便,所以想换成中文。然后发现在终端输入 Java 命令得到的是中文: ![]( https://rayforgit.github.io/2017/03/17/遇到的小问题合集 /s1.png)
    这两个应该是相关的。 然后修改系统字体: ![]( https://rayforgit.github.io/2017/03/17/遇到的小问题合集 /s3.png)
    发现可以显示成英文,但是目的是只是 Java 为英文,所以不想这样。 尝试过的方法:

    全都不行....那么我到底应该在哪里设置?

    6 回复  |  直到 2017-04-11 17:42:18 +08:00
        1
    misaka19000   2017-04-11 16:24:35 +08:00 via Android
    排版太乱了,看不下去
        2
    chocotan   2017-04-11 16:49:10 +08:00
    试试
    Editor->Colors & Fonts->Font 里使用支持中文的 Secondary font
        3
    Kilerd   2017-04-11 17:00:59 +08:00
    图片全部看不了,怎么看问题??

    发帖之前为啥不先预览一下呢??? 坏毛病!!
        4
    luckyrayyy   2017-04-11 17:02:49 +08:00
    @Kilerd 不好意思...直接从 github 上贴出来的,想着应该都是 markdown 没问题的..抱歉抱歉
        5
    luckyrayyy   2017-04-11 17:33:40 +08:00
    问题解决了....原来 idea.vmoptions 是 32 位的程序的设置, 64 位的没有。
    点击 Edit->Edit Custom VM Option 会生成一个 64 位的配置文件,然后再添加-D 巴拉拉巴拉就行了....
    害得我号还被封了.....
        6
    sagaxu   2017-04-11 17:42:18 +08:00
    系统 locale 改成英文,妥妥的
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2614 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 22ms · UTC 14:17 · PVG 22:17 · LAX 06:17 · JFK 09:17
    ♥ Do have faith in what you're doing.