首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
宝塔
V2EX  ›  Sublime Text

sublime text 这么多版本过去了,毛病还是没改啊....

  •  
  •   CodemonkeyM · 2017-11-02 10:36:44 +08:00 · 2846 次点击
    这是一个创建于 747 天前的主题,其中的信息可能已经有所发展或是发生改变。

    编辑一个文件,按下 crtl+s 之后,就弹窗提示文件已修改,是否重新加载...以前就是因为这个毛病卸载的...现在新版本还是这毛病....

    13 回复  |  直到 2017-11-02 16:47:47 +08:00
        1
    jfcherng   2017-11-02 10:57:59 +08:00
    沒遇過,但你能 https://github.com/SublimeTextIssues/Core 提 issue
        2
    watzds   2017-11-02 11:00:35 +08:00 via Android
    这一般是文件被外部修改了吧,这说明版本变化,但是你的运行环境一直没变而已。
        3
    vegito2002   2017-11-02 11:01:19 +08:00 via iPad
    没碰到过这个问题
        4
    CodemonkeyM   2017-11-02 11:04:23 +08:00
    @watzds 并没有外部修改...
        5
    TimePPT   2017-11-02 11:13:21 +08:00
    设置里倒是有个 "always_prompt_for_file_reload" 但也管的是外部修改后的提示,你先看看设为 false 管用不
        6
    bbxiong   2017-11-02 13:04:12 +08:00 via iPad
    我也发现有这个问提,特别是频繁保存的时候(打字就 ctrl +s 习惯了)
        7
    x7395759   2017-11-02 13:14:54 +08:00
    从来没有遇到过
        8
    CodemonkeyM   2017-11-02 13:31:48 +08:00
    @TimePPT 谢了,我试下.
        9
    stillsilly   2017-11-02 13:42:53 +08:00
    为什么我从没遇到过……
        10
    hguandl   2017-11-02 14:07:30 +08:00   ♥ 1
    这应该是 Convert to UTF8 那个插件的锅吧。比如你编辑一个 GBK 编码的文件(在 Windows 上极为常见),在保存后就会弹窗,挺烦人的。
        11
    TimePPT   2017-11-02 15:50:44 +08:00
    @hguandl 试了下还真是。
    在 Windows 下创建了非 UTF-8 的文本文件,用装了 Convert to UTF8 插件的 Sublime Text 3 打开,setting 里"always_prompt_for_file_reload" 选项设为 trule,编辑后 Ctrl+s 保存会弹窗提示。
    "always_prompt_for_file_reload" 设为 false 后解决。

    @CodemonkeyM @bbxiong 可以试下
        12
    TimePPT   2017-11-02 15:51:16 +08:00
    @TimePPT 选项设为 trule ——>选项设为 true
        13
    bbxiong   2017-11-02 16:47:47 +08:00
    @TimePPT 改了后有效果,谢谢
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3897 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 30ms · UTC 09:48 · PVG 17:48 · LAX 01:48 · JFK 04:48
    ♥ Do have faith in what you're doing.