首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  PHP

Apache 2.4 可以跑 PHP 5.2 吗?

  •  
  •   blues9 · 2018-10-28 01:49:00 +08:00 · 1843 次点击
    这是一个创建于 380 天前的主题,其中的信息可能已经有所发展或是发生改变。

    一个很老的系统用的 php5.2 和对应的 zend 加密,用的 apche2.2.x,现在想把 web server 升级到 apache2.4,但是编译出的 ibphp5.so 总是不能 load:undefined symbol: unixd_config

    是不是 php5.2 和 apache2.4 不兼容啊。。。

    3 回复  |  直到 2018-10-31 21:53:28 +08:00
        1
    ivmm   2018-10-28 02:01:33 +08:00
    用 PHP-FPM 模式估计可行,不要用 mod php
        2
    alect   2018-10-28 10:59:13 +08:00
    php-fpm ,还能加载多个版本
        3
    blues9   2018-10-31 21:53:28 +08:00 via iPhone
    更新一下,折腾了好几天 php-fpm+apache2.4 没搞定,后来改用 nginx 搞定了。
    不过感觉 nginx 下图片 load 慢了,感觉不如 apache+mod_php 时那么顺畅,网站流量很小,图片比较多,原以为 mginx 会快很多,各种典型参数都配了,感觉也没效果。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4067 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 22ms · UTC 07:48 · PVG 15:48 · LAX 23:48 · JFK 02:48
    ♥ Do have faith in what you're doing.