首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Vim

🦄 一篇文章讲清楚如何安装 vim 插件

  •  1
     
  •   billyangg · 308 天前 · 3343 次点击
    这是一个创建于 308 天前的主题,其中的信息可能已经有所发展或是发生改变。

    正确安装 Vundle

    之所以写这篇文章,其一是打算用 vim 来写 python 后端代码。笔者有两台电脑一台 PC 一台 MBP,在 PC 上安装 Vundle 插件遇到了几个坑,这里顺便写篇文章记录一下,废话不多说 let's dive in

    正确安装依赖

    如要使用 Vundle 必须安装 Git 和 Curl,在 windows 中通常使用 chocolatey 来安装各种包,如果你没有使用过 chocolatey,首先需要安装:

    按照官网安装方法一步一步走即可:chocolatey 官网

    然后安装 Git 和 Curl,如果已经安装过则跳过这一步:

    C:\> choco install -y git
    C:\> choco install -y curl
    

    20190131085706.png

    这样表示安装成功

    Vundle 安装前的准备

    参考官方安装指引 Vundle on Windows

    首先遇到的第一个坑就是文件夹不同的命名方式:

    By default, Vim on Windows will still look for .vimrc and install to ~/.vim. This doesn't work perfectly on Windows as the files aren't hidden, but .gitignore files are used in the same manner fairly commonly. You could for example change .vimrc to _vimrc and .vim to vimfiles - this would then require a change to the example vimrc below.

    因为上述原因,建议将 .vimrc 改名为 _vimrc 以及 .vim 文件夹名称改为 vimfiles

    然后是环境变量:

    Additionally, if you've set %HOME% environmental variable to some directory, that's the directory vim will search as ~/, thus you have to put .vimrc file and ~/.vim folder under the directory or remove %HOME% from environmental variable settings to use %USERPROFILE% as default.

    如果你修改了 %HOME% 的指向,那么你需要将其删除,并默认使用 %USERPROFILE%

    Vundle 开始安装

    进入到用户根目录,然后使用 git 命令获取 Vundle 并编辑 .vimrc 或 _vimrc

    cd %USERPROFILE%
    git clone https://github.com/VundleVim/Vundle.vim.git %USERPROFILE%/.vim/bundle/Vundle.vim
    gvim .vimrc # 或使用 vim .vimrc
    

    打开官方指引 Quick Start-3. Configure Plugins

    20190131090654.png

    将其中的代码全部 copy 到 .vimrc 或 _vimrc 文件中去:

    20190131090710.png

    修改其中部分代码:

    set rtp+=~/.vim/bundle/Vundle.vim
    call vundle#begin()
    

    改为:

    set rtp+=$HOME/.vim/bundle/Vundle.vim/
    call vundle#begin('$HOME/.vim/bundle/')
    

    修改这个也是因为路径问题

    修改 .vimrc

    最后关闭并重新打开一个终端,修改 .vimrc 清理掉暂时不用的 Plugin:

    20190131091253.png

    在红色箭头之间的都是我们需要安装的 Plugins,其中 Plugin VundleVim/Vundle.vim 蓝色箭头部分不可删,这个是 Vundle 管理插件的插件

    Plugin 'rstacruz/sparkup', {'rtp': 'vim/'} 这个插件最好也不要删掉,如果出现错误尝试修改成 Bundle 'rstacruz/sparkup', {'rtp': 'vim'}

    Trailing slash issue

    我们将其他插件暂且删除:

    修改后的文件长这样:

    20190131091936.png

    然后 :wq 关闭文件,命令行中执行 vim

    安装插件

    准备操作完成后我们就可以去安装插件了

    第一种安装方式 使用 PluginInstall 命令

    然后执行安装 plugin 操作:

    :PluginInstall

    安装过程中耐心等待

    20190131092102.png

    出现 done 即安装完成:

    20190131092141.png

    :q 关闭

    然后我们尝试安装其他插件:

    搜索插件 :PluginSearch colorscheme

    20190131092309.png

    选择一个你想要安装的插件,并敲击键盘 i 来安装这个插件:

    20190131092421.png

    正在安装:

    20190131092433.png

    安装完毕:

    20190131092456.png

    然后选中这个插件的名称,并粘贴到 .vimrc 文件中去:

    20190131092751.png

    关闭并退出,这样这个插件就算安装完毕了

    执行 :PluginList 查看我们已经安装过的插件:

    20190131093032.png

    第二种方式 浏览 vimAwesome 网站

    vimawesome 网站提供了大量的不错的 vim 插件列表,可以在这个网站里搜索各种插件

    20190131093208.png

    比如这里搜索 vim-airline,直接复制红色箭头部分的代码

    20190131093549.png

    将代码粘贴到 .vimrc 中去

    20190131093620.png

    然后执行 :PluginInstall 就会自动将这个插件安装好:

    20190131093734.png

    查看效果:

    20190131094054.png

    20190131094113.png

    20190131094124.png

    删除插件

    删除插件也很简单,首先进入到 vim 并执行 :PluginList 然后选择你想要删除的插件,并使用快捷键 shift + D,退出,打开 .vimrc 文件将你删除的那个插件从配置文件中删掉即可

    OK 就这么多更多好用的插件大家自己去探索吧

        1
    iam070   308 天前
    赞一个,不过 Vundle 比较老了,现在一般推荐 vim-plug 和 dein
        2
    newbieRenew   308 天前 via iPhone
    现在逐渐用 vim8 自带的包管理了
        3
    quinoa42   308 天前 via Android
    我前段时间从 vim-plug 换成 vim8 自带 packages 了
    以前都是一行代码就 it just works,现在需要自己从零开始理解整个流程,感觉还不错
        4
    aaa5838769   308 天前
    真佩服- -,我就不愿意用 vim 写 python。
        5
    honist   308 天前 via iPhone
    有毅力。不需要。建议 lz 稍微精炼一下,:q 可以不提啦
        6
    lihongjie0209   308 天前
    从文本编辑器进化到 IDE
        7
    billyangg   308 天前
    @iam070 谢谢老哥提醒 前端入坑后端还很多不懂 :p
        8
    billyangg   308 天前
    @newbieRenew 了解了 谢老哥提醒
        9
    billyangg   308 天前
    @quinoa42 看样子现在装插件很轻松了 我连 vim-plug 都不知道;简单了解了一下很好用关键还是并行下载安装 :)
        10
    billyangg   308 天前
    @honist 前面几位都建议用 vim-plug 了 看来我这是太落后了 哈哈哈
        11
    yzlnew   308 天前
    😄,我也是刚从 Vundle 中解脱出来用 vim-plug 了
        12
    Yggdroot   307 天前 via Android   ♥ 1
    vimawesome 是个不错的网站,但是还是不建议到这里找插件。因为马太效应,排在前面的会永远排在前面,而一些更好的插件就因为比较新,可能永远不会被发现。上面靠前的插件只能说明曾经很好并且时间比较久,比如楼主的 vundle 就已经过时了。建议多到一些 vim 论坛逛逛,看看一些比较新的信息。
        13
    billyangg   307 天前
    @Yggdroot 谢大佬建议 我是前端 对后端不是很懂 也是看各位童鞋提醒才知道 原来 vundle 已经很久远了 :)
        14
    billyangg   307 天前
    @yzlnew 对的 看到各位提醒才发现 vundle 已经这么过时的东西了。。。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1019 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 19:47 · PVG 03:47 · LAX 11:47 · JFK 14:47
    ♥ Do have faith in what you're doing.