首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  程序员

IDEA 控制台输出中文乱码,网上能用的方法都试过了还是不行,请指点

  •  1
     
  •   Seesa · 141 天前 · 2258 次点击
    这是一个创建于 141 天前的主题,其中的信息可能已经有所发展或是发生改变。

    之前一直用 MyEclipse,这两天开始转入使用 IDEA,然后发现控制台输出中文乱码,怎么都解决不了,网上能搜到的方法几乎都尝试过了,还是不行,所以来请教下,看看有没有大佬能帮忙解决下。

    电脑系统:win8.1

    idea 版本:2019.1.2

    参考: https://blog.csdn.net/u013626215/article/details/88287038

    解决步骤: 第一步: 修改 intellij idea 配置文件:

    找到 intellij idea 安装目录,bin 文件夹下面 idea64.exe.vmoptions 和 idea.exe.vmoptions 这两个文件,分别在这两个文件中添加:-Dfile.encoding=UTF-8 (已设置)

    第二步: 找到 intellij idea 的 file — settings — Editor — FileEncodings 的 GlobalEncoding 和 ProjectEncoding 和 Default encoding for properties 都配置成 UTF-8 (要修改,不能使用默认的)(已设置)

    第三步: 在部署 Tomcat 的 VM options 项中添加:-Dfile.encoding=UTF-8 (已设置)

    第四步: 重启 Intellij idea 即可解决乱码问题

    以上是链接里的解决步骤。

    我还有其他的设置

    1.去 tomcat 的安装目录,修改 server.xml 文件,在 Connector 标签内添加 URIEncoding="UTF-8"

    2.有人说可能是主题字体的问题,File - Setting - Appearance&Behavior - Appearance,修改字体为“ Microsoft Yahei ”

    3.查看项目目录的 .idea 目录下的 encodings.xml 文件中的字符集编码设置

    以上设置均无法解决控制台输出中文乱码的问题,所以我就不知道该如何处理了。

    还有几点忘了说:

    1.正常的输出打印语句,中文是正常显示的

    2.下面的状态栏[0:Message],里面提醒的 Warning 信息,中文也是正常显示的

    3.只有 [项目启动失败] , [异常报错的中文显示乱码]

    =============================================

    请大佬指点。

    17 回复  |  直到 2019-05-28 18:52:07 +08:00
        1
    zwb9412   141 天前 via Android
    默认读取的 idea64.exe.vmoptions 或 idea.exe.vmoptions 是程序 bin 目录下的,但也可能是当前用户文档目录下的(貌似是安装时选的导入之前配置造成的)。如果读取的是文档目录下的配置文件,那你只修改 bin 下的就不会生效。具体读取哪个目录可以用 visualVM 查看一下。
        2
    securityCoding   141 天前
    log 组件编码查一下
        3
    szq8014   141 天前
    最好截图发出来证明你的确改对了,万一你打错了字母呢
        4
    qwerthhusn   141 天前 via iPhone
    系统:win8.1 这年头还有人在用 win88 唉
        5
    skypyb   141 天前 via Android
    你的文件格式是 utf-8 么
        6
    Fazauw   141 天前 via Android
    这些问题太让人头大。我比较懒,code 的时候就不留任何非英文元素
    包括系统,语言,地区,注释等等。
        7
    Luckyray   141 天前
    Help->Edit Custom VM Option 会生成一个 64 位的配置文件,然后再添加-D 巴拉拉巴拉就行了....
        8
    laodao1990   141 天前
    遇到过这个问题,但是忘了怎么改的了。
    但是你上面的两种方式肯定是不对的,idea 那个是改的文件编码,tomcat 那个是 url 参数编码。

    依稀记得好像是在 preferences-> xxx 里加了个什么参数,你再 google 查查吧。
        9
    laodao1990   141 天前
        10
    Seesa   141 天前
        11
    Seesa   141 天前
    @securityCoding 谢谢啊,没有上 log 组件啊
        12
    Seesa   141 天前
    @skypyb 是啊
        13
    Seesa   141 天前
    @Luckyray 谢谢啊,试过了不行。。。
        14
    Seesa   141 天前
    @laodao1990 谢谢啊,你这个早就试过啦,不行。。。
        15
    ttttturf   141 天前 via iPhone
    Tomcat 乱码? tomcat 配置文件改成 gbk
        16
    Seesa   140 天前
    @zwb9412
    @securityCoding
    @szq8014
    @skypyb
    @Luckyray
    @laodao1990
    ------------------------------------
    感谢以上所有帮忙回答问题的同学谢谢你们。
    问题解决了。。。
    我用的 Tomcat 版本是 Tomcat8.0.53
    我换了个 Tomcat1.0.65 ,然后控制台中文不再乱码了。。。
    尴尬。。。
        17
    hhw123   140 天前 via iPhone
    tomcat 改成 gbk
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3295 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 10:27 · PVG 18:27 · LAX 03:27 · JFK 06:27
    ♥ Do have faith in what you're doing.