首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Tumblr
V2EX  ›  中州韻

鼠须管更新 0.12.0 之后无法部署的解决方法

  •  
  •   Tumblr · 2019-06-17 13:07:54 +08:00 · 5086 次点击
    这是一个创建于 385 天前的主题,其中的信息可能已经有所发展或是发生改变。

    首先邀请公子 @lotem 璐璐 @Prcuvu

    Mac OS ( Catalina )刚更新 Squirrel 到 0.12.0,在定义输入法之后 deploy 的时候,会报错,查看日志如下:

    table format version 3 is no longer supported. please upgrade to version Rime::Table/4.0

    后尝试重新安装输入法:

    sudo bash rime-install rime-wubi rime-pinyin-simp rime-bopomofo rime-terra-pinyin
    

    安装完成后重新 deploy,正常通过。

    我想,很多鼠须管的用户可能会困此困扰,是否可以在 wiki 中添加一些说明方案?

    BTW,强推推荐SquirrelWeasel,配合语言模型使用效果更佳!

    14 条回复    2019-07-31 16:08:54 +08:00
    huaxianyan
        1
    huaxianyan   2019-06-17 13:36:57 +08:00
    这个语言模型我还没太读懂直观的效果怎么体现
    Tumblr
        2
    Tumblr   2019-06-17 15:02:22 +08:00
    @huaxianyan #1 我也在学习了解中,目前最直观的体验就是词库强大了,分词也更智能了些。
    Jobin0528
        3
    Jobin0528   2019-06-17 15:54:38 +08:00
    @Tumblr #2 怎么可以知道语言模型生效 了?我用的五笔`拼音混合输入,感觉不到变化
    dazkarieh
        4
    dazkarieh   2019-06-17 20:29:55 +08:00
    刚升到 0.12 ,一切顺利,没有遇到楼主的部署问题
    Tumblr
        5
    Tumblr   2019-06-17 20:40:07 +08:00
    @dazkarieh #4 我是升级上来没问题,一部属就报错了,重新安装 schema 之后就好了。
    其实最开始是五笔和注音报错,更新了这两个之后,地球拼音报错(注音依赖),但整个过程中袖珍拼音(五笔依赖)并没有报错。
    huaxianyan
        6
    huaxianyan   2019-06-19 13:57:53 +08:00
    @Tumblr 我也安装了,感觉好像没生效?

    下载了数据包,把 grammar.yaml 以及 2 个 gram 文件放到 Rime 用户文件夹,修改方案文件加入配置

    重新部署的时候闪了一下就消失,我怀疑是没有安装插件的原因

    所以楼主能教一下怎么安装 librime-octagram 插件吗?
    czjackjin
        7
    czjackjin   2019-06-27 15:49:15 +08:00
    mac 应该是自带了吧,你看下更新说明,另外,数据包哪里下载呢?
    dazkarieh
        8
    dazkarieh   2019-07-02 23:36:59 +08:00
    @Tumblr 老哥,可以共享一份朙月拼音的配置吗,不懂怎么配置这个八股文插件。
    @czjackjin #7,佛振放了两个数据源,好象没有针对鼠须管配置的详细说明。
    https://github.com/lotem/rime-octagram-data
    https://github.com/lotem/rime-octagram-data-s1
    Tumblr
        9
    Tumblr   2019-07-02 23:58:56 +08:00
    @dazkarieh #8 我不用拼音。。。
    dazkarieh
        10
    dazkarieh   2019-07-03 00:28:07 +08:00
    @Tumblr #9 五笔也行啊
    czjackjin
        11
    czjackjin   2019-07-03 10:40:55 +08:00
    现在是 14.0 了,可以输入日期了
    Tumblr
        12
    Tumblr   2019-07-03 10:58:55 +08:00
    @dazkarieh #10 我推荐这篇文章给你吧,非常不错:
    https://scomper.me/gtd/-shu-xu-guan-de-diao-jiao-bi-ji
    BTW,很喜欢他的博客风格。
    dazkarieh
        13
    dazkarieh   2019-07-03 11:25:49 +08:00
    @Tumblr #12 谢谢推荐,之前比较各家方案的时候用过这个配置,用不习惯又自己折腾了一个版本。

    scomper 最近一次更新是 2 个月前,对鼠须管 0.12.0 新增的两款插件 lbrime-lua、librime-octagram 并没有跟进,主要不懂针对全拼、双拼、五笔等不同输入法方案,librime-octagram 插件是怎么配置的。

    比如我自己定制加载了几十万的搜狗词库,那如何分辨是使用了八股文的功效还是原先搜狗海量词库的功效?

    后续:我已经在[wubi98 方案]( https://github.com/yanhuacuo/98wubi )里看到应用了,而且提了 issue,佛振大佬及时给出了实例测试。

    - 各個國家有各個國家的國歌
    - 充滿希望的跋涉比到達目的地更能給人樂趣
    hronro
        14
    hronro   341 天前
    @dazkarieh 在 [wubi98 方案] 仓库中并没有发现相关 issue,能否分享一下 librime-octagram 插件究竟需要怎么配置呢?
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1011 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 37ms · UTC 21:36 · PVG 05:36 · LAX 14:36 · JFK 17:36
    ♥ Do have faith in what you're doing.