V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
99long
V2EX  ›  程序员

绿盟扫描 jquery-1.7.1.min.js 是的网站存在漏洞,升级到哪个版本比较好那

  •  
  •   99long · 2019-11-29 14:49:45 +08:00 · 2938 次点击
    这是一个创建于 946 天前的主题,其中的信息可能已经有所发展或是发生改变。

    这次网站被扫描出使用了 jquery-1.7.1.min.js ,说这个对网站还有些威胁,不知道换到哪个版本兼容更好,版本有最新

    11 条回复    2019-11-29 19:01:19 +08:00
    shintendo
        1
    shintendo  
       2019-11-29 14:55:32 +08:00
    当然是 1.x 的最新版
    99long
        2
    99long  
    OP
       2019-11-29 15:12:21 +08:00
    @shintendo 老程序,怕最新版本的 jquery,即使是 1.x 的版本,也会出现不兼容的问题,只是担心
    shehuizhuyi
        3
    shehuizhuyi  
       2019-11-29 15:16:24 +08:00
    前端有没有漏洞没有用吧
    lxk11153
        4
    lxk11153  
       2019-11-29 15:33:02 +08:00
    “绿盟扫描” 规则里 exclude 掉 jquery 就没有漏洞了。/HJ
    fengjianxinghun
        5
    fengjianxinghun  
       2019-11-29 16:07:45 +08:00
    告诉你正确的办法,把文件名和文件开头的注释版本号 jquery-1.7.1 改成高版本的就行了
    TomatoYuyuko
        6
    TomatoYuyuko  
       2019-11-29 16:14:53 +08:00
    jquery 有向下兼容补丁,但是还有很多地方需要手动改,不过基本还算是清晰.
    刚做完 1.3=>3.4 的洗礼,现在神清气爽
    lizhen2096
        7
    lizhen2096  
       2019-11-29 16:30:38 +08:00
    把版本号改成 x.y.z 就好了
    ClarkAbe
        8
    ClarkAbe  
       2019-11-29 17:18:41 +08:00 via Android
    @shehuizhuyi #3 一行 js 改变你的整个页面
    DevilHunterXX
        9
    DevilHunterXX  
       2019-11-29 17:24:22 +08:00
    最新版的 AWVS 即使将低版本 jquery 中的版本号去掉,依旧能扫描出这个问题来
    gefranks
        10
    gefranks  
       2019-11-29 18:35:22 +08:00 via iPhone
    把 CVE 的 fix 代码 merge 到自己用的 jquery 里面
    virusdefender
        11
    virusdefender  
       2019-11-29 19:01:19 +08:00
    版本扫描,隐藏下版本就好了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2515 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 25ms · UTC 08:35 · PVG 16:35 · LAX 01:35 · JFK 04:35
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.