首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
V2EX  ›  问与答

有没有使用 kinect 做开发或是学术的?我想问一下 kinect 的不同版本

  •  
  •   JConlee · 2014-10-27 12:36:06 +08:00 · 2827 次点击
    这是一个创建于 1866 天前的主题,其中的信息可能已经有所发展或是发生改变。
    最近学术课题需要用到kinect,按理说应该购置kinect for windows来做开发,但是无奈价格过高,要1300块。硬件基本相同的kinect xbox360版本只需要600块。
    但是微软对xbox版本的kinect做了限制,似乎缺少了许多功能,而且没有near mode(离物体最近距离为0.8m)。
    xbox one发布后,微软也推出了kinect v2版,售价也在1300元左右,但是如果在windows下使用的话,硬件要求过高了(i7 2.3Ghz,DX11显卡),我的笔记本实在带不动。

    我想问的是,如果用xbox360版的kinect做开发,有哪些不便?缺少near mode是不是很要命?微软官方的kinect for windows sdk能用到哪个版本?

    其实华硕也有一款类似的体感设备asus xtion pro live,但好像用的人不多。
    专门做RGB-D开发的OpenNI开源项目似乎也半死不活了,唉,真是难办啊。
    5 回复  |  直到 2014-10-27 16:23:55 +08:00
        1
    allenforrest   2014-10-27 12:41:38 +08:00
    我们在用 ROS 里的 Kinect 代码。
        2
    JConlee   2014-10-27 12:45:13 +08:00
    @allenforrest kinect硬件是哪个版本呢?支不支持near mode
        3
    allenforrest   2014-10-27 12:47:20 +08:00
    @JConlee kinect 硬件就是普通的 xbox360版本,淘宝买的,6,700块,华硕的应该也可以的。

    不过我们后来换掉了,kinect 的传感器精度实在是差的太远,我们后来换了比较高端的激光传感器。
        4
    virusdefender   2014-10-27 12:54:18 +08:00
    之前在实验室做过 xbox的和for windows的我们暂时发现什么大的区别,可能是精度要求不高的原因。
    kinect1的sdk最新是1.8,kinect2的sdk和1差别挺大的。
        5
    grzhan   2014-10-27 16:23:55 +08:00
    以前基友用OpenNI在Linux上跑过kinect1 [其实也是ROS啦
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1221 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 21ms · UTC 17:57 · PVG 01:57 · LAX 09:57 · JFK 12:57
    ♥ Do have faith in what you're doing.