V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
iOS 开发实用技术导航
NSHipster 中文版
http://nshipster.cn/
cocos2d 开源 2D 游戏引擎
http://www.cocos2d-iphone.org/
CocoaPods
http://cocoapods.org/
Google Analytics for Mobile 统计解决方案
http://code.google.com/mobile/analytics/
WWDC
https://developer.apple.com/wwdc/
Design Guides and Resources
https://developer.apple.com/design/
Transcripts of WWDC sessions
http://asciiwwdc.com
Cocoa with Love
http://cocoawithlove.com/
Cocoa Dev Central
http://cocoadevcentral.com/
NSHipster
http://nshipster.com/
Style Guides
Google Objective-C Style Guide
NYTimes Objective-C Style Guide
Useful Tools and Services
Charles Web Debugging Proxy
Smore
JEFFMEME
V2EX  ›  iDev

MAC 10.11 命令行报错,如何修复

  •  
  •   JEFFMEME · 2015-09-01 12:55:50 +08:00 · 20893 次点击
    这是一个创建于 2590 天前的主题,其中的信息可能已经有所发展或是发生改变。
    MAC 10.11 命令行报错,如何修复
    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools ), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
    29 条回复    2019-12-03 09:56:26 +08:00
    solar
        1
    solar  
       2015-09-01 14:38:43 +08:00   ❤️ 4
    重新安装下 Xcode Command Line Tools 试试。
    JEFFMEME
        2
    JEFFMEME  
    OP
       2015-09-02 06:03:20 +08:00   ❤️ 1
    @solar xcode-select --install 谢谢 重装后可以啦
    lp380490944
        3
    lp380490944  
       2017-03-21 17:10:56 +08:00   ❤️ 1
    搜到这里,回答的不具体,留给后人: xcode-select --install
    ideacco
        4
    ideacco  
       2017-08-14 01:00:48 +08:00
    搜到这里,感谢。药到病除
    hzzz0823
        5
    hzzz0823  
       2017-09-28 10:21:15 +08:00
    后人++
    cokky
        6
    cokky  
       2017-09-28 17:50:57 +08:00
    新 OS 升级这问题又冒出来了。药到病除,感谢!
    chenkaiyuan1993
        7
    chenkaiyuan1993  
       2017-10-06 13:54:34 +08:00
    后人++ ,macOS High Sierra
    lixueli
        8
    lixueli  
       2017-10-16 16:23:23 +08:00
    macOS 10.13 同
    xiaochunyong
        9
    xiaochunyong  
       2017-10-17 17:57:37 +08:00
    macOS 10.13 +1
    mtou091
        10
    mtou091  
       2017-10-18 17:18:56 +08:00
    同上
    Azeril
        11
    Azeril  
       2017-10-19 17:12:03 +08:00
    macOS 10.13 +2333
    zhoulouzi
        12
    zhoulouzi  
       2017-10-20 17:53:11 +08:00
    macOS High Sierra++ 手贱升级了
    zhangzhang
        13
    zhangzhang  
       2017-11-16 18:22:10 +08:00
    后人++
    zhy
        14
    zhy  
       2017-11-17 11:52:04 +08:00
    +一楼
    GavinChou
        15
    GavinChou  
       2017-11-21 13:53:01 +08:00
    macOS High Sierra, 后人++
    testcount
        16
    testcount  
       2017-11-26 19:44:21 +08:00
    后人++
    macOS 10.13 +1
    wangofjian
        17
    wangofjian  
       2017-11-29 23:04:40 +08:00
    感谢前人领路
    viquuu
        18
    viquuu  
       2017-12-07 21:00:14 +08:00
    后人++
    卸载了 XCODE,出现了这个错误。
    resolvewang
        19
    resolvewang  
       2017-12-11 18:26:54 +08:00
    后人+++
    很强
    caomaocao
        20
    caomaocao  
       2017-12-26 11:49:52 +08:00
    后人+++
    shuirong1997
        21
    shuirong1997  
       2018-01-08 16:06:53 +08:00
    后人++++
    感谢 Google,前人...
    ayang23
        22
    ayang23  
       2018-02-08 21:46:11 +08:00
    感谢前人+++++
    firejoke
        23
    firejoke  
       2018-06-08 08:42:40 +08:00
    手贱装了 Xcode10bate,装了 Mojave 预览版,而且因为 app store 改版了的原因吧,用 xcode-select --install 这个命令选安装的话,会报错软件更新服务连不上,最后在新版商店里重新下载了 Xcode9,而且还要把 Xcode10 和一堆相关文件删掉才能装......
    xiaochocking
        24
    xiaochocking  
       2018-09-27 16:58:19 +08:00
    macOS Mojave 10.14 报到
    kgbook
        25
    kgbook  
       2018-10-08 23:58:33 +08:00
    升级到 macOS Mojave 10.14 出问题了......
    ```shell
    $ xcode-select --install
    xcode-select: error: command line tools are already installed, use "Software Update" to install updates
    ```
    `softwareupdate --install -a` 更新软件,参见 https://stackoverflow.com/a/34617930/5393174。
    CODEWEA
        26
    CODEWEA  
       2018-10-18 12:33:14 +08:00
    macOS Mojave 10.14 报到
    mikezhang0515
        27
    mikezhang0515  
       2018-10-30 17:18:23 +08:00
    macOS Mojave 10.14 报到
    meowoo
        28
    meowoo  
       2018-10-31 20:33:00 +08:00
    macOS Mojave 10.14 报到

    xcode-select --install 需要安装命令行工具,无法链接服务器

    softwareupdate --install -a 下载 10.14.1 失败,Error downloading macOS 10.14.1 更新: 请求超时。

    现在在更新 xcode
    akatquas
        29
    akatquas  
       2019-12-03 09:56:26 +08:00
    macOS Catalina
    Version 10.15.1 ++
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   888 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 42ms · UTC 20:22 · PVG 04:22 · LAX 13:22 · JFK 16:22
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.