首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Node.js
Express
PPA for Ubuntu
ppa:chris-lea/node.js
V2EX  ›  Node.js

centOS 6.x 如何安装 node 4.x

  •  
  •   RoshanWu · 2015-10-13 13:40:33 +08:00 · 3910 次点击
    这是一个创建于 1492 天前的主题,其中的信息可能已经有所发展或是发生改变。

    貌似 c++ 编译器版本太低。。。

    17 回复  |  直到 2015-10-19 12:02:10 +08:00
        1
    loveyu   2015-10-13 13:57:45 +08:00
    不是直接有二进制版本么,试试看能不能用
        2
    Chrics   2015-10-13 14:14:13 +08:00
    换源...centos 的官方源各种蛋疼...
        3
    RoshanWu   2015-10-13 14:39:53 +08:00
    @Chrics 貌似国外的源速度巨慢,也不知道怎么搞代理,太艰难模式了。。。
        4
    RoshanWu   2015-10-13 14:40:16 +08:00
    @loveyu 就是用源码编译安装呀
        5
    zieglar   2015-10-13 14:45:52 +08:00
    gcc++ 版本不够,我已经把服务器换成 7.x
        6
    loveyu   2015-10-13 14:46:19 +08:00
    @RoshanWu https://nodejs.org/dist/v4.2.0/node-v4.2.0-linux-x64.tar.gz 比如这个下载得到的我在 centos7 上可以直接运行,不需要编译,你可以试试
        7
    RoshanWu   2015-10-13 15:23:31 +08:00
    @loveyu 用什么服务器不是我们所能决定的,所以只能选择不上 4.x 了,哭。。。
        8
    hxtheone   2015-10-13 15:33:14 +08:00
    从来没有编译过 node ,每次都是直接用 nvm 下二进制版本,开箱即用,简单粗暴
        9
    adrianzhang   2015-10-13 15:51:04 +08:00
    几种解决办法:
    1 、升级 gcc 等进行编译安装
    2 、 Docker ,编译安装或直接运行一个官方 Nodejs4.0 镜像。
    3 、二进制,直接用。
        10
    loveyu   2015-10-13 18:06:01 +08:00
    @RoshanWu 我的意思是你在 centos6 上试试看能不能用,我刚在 centos6 x86 上试了下,能够跑起来。
        11
    learnshare   2015-10-13 18:27:15 +08:00
    编译安装
        12
    RoshanWu   2015-10-13 22:12:24 +08:00
        13
    loveyu   2015-10-13 22:36:21 +08:00   ♥ 1
    @RoshanWu 使用别人提供的二进制包,不是需要编译的源代码啊。
    https://nodejs.org/en/download/ Linux Binaries (.tar.gz) 那么清楚
        14
    RoshanWu   2015-10-13 23:32:37 +08:00
    @loveyu 多谢
        15
    Amit   2015-10-14 00:36:54 +08:00
    问一下 4.x 能兼容老版本的应用吗
        16
    pkking   2015-10-14 09:56:14 +08:00   ♥ 1
        17
    Jeepeng   2015-10-19 12:02:10 +08:00
    先安装 nvm ,然后:
    nvm install v4.2.1
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   934 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 22ms · UTC 21:58 · PVG 05:58 · LAX 13:58 · JFK 16:58
    ♥ Do have faith in what you're doing.