首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  前端开发

现阶段入前端,不考虑兼容性。是否可以只选 es6 或 typescript 中的一种?

  •  
  •   ucun · 327 天前 · 1094 次点击
    这是一个创建于 327 天前的主题,其中的信息可能已经有所发展或是发生改变。

    之前做一些项目都是套模板

    现在想点点前端技能树

    就目前阶段,是否可以只选 es6 或 typescript 中的一种?

    8 回复  |  直到 2018-12-29 16:33:27 +08:00
        1
    bestie   327 天前
    可以
        2
    shintendo   327 天前
    不考虑兼容性是什么意思……浏览器能跑 typescript 了吗
        3
    maichael   327 天前
    可以。
        4
    bestie   327 天前
    @shintendo 现阶段跑在浏览器上的基本都是编译过的,所以不考虑兼容性也没什么问题
        5
    learnshare   327 天前
    用 ES6+ 和 TypeScript 跟兼容性没关系,跑的代码都是编译后的
        6
    nonoroazoro   327 天前
    因为 TypeScript 是 JavaScript 的超集,并且加上了类型系统(可选),一举两得,你不会后悔的。
        7
    feverzsj   327 天前
    ts 会让一般的开发变得更麻烦,没什么太大意义,用 es 就足够了
        8
    Gathaly   295 天前
    es6 吧,typescript 后期没人维护就麻烦了
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2373 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 14:37 · PVG 22:37 · LAX 07:37 · JFK 10:37
    ♥ Do have faith in what you're doing.