首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
宝塔
V2EX  ›  Linux

VNCServer 服务 跟 本地 GDM 抢 Display ?

  •  
  •   johnsonshu · 76 天前 · 1469 次点击
    这是一个创建于 76 天前的主题,其中的信息可能已经有所发展或是发生改变。
    Redhat 7
    已经用 systemctl enable [email protected] 设为开机启动。

    但是,vncserver 常常启动失败,原因是它默认的 display :0 , 被笔记本自身的 gdm/X session 先占用了。

    如果我手动 systemctl start vncserver 一下, 系统就会在自动在 :1 上启动完成 vncserver, 没什么问题。

    但是好烦每次还得手动启动一下,而且我希望 vncserver 在 :0 上, 有没有什么办法?
    3 回复  |  直到 2019-09-02 13:04:40 +08:00
        1
    raysonx   76 天前
    你可能需要 x0vncserver
        2
    johnsonshu   76 天前
    @raysonx 不行。 默认的 tigervnc 的 vncserver 已经是最优的了。 只是设置方面让我烦恼。 对 X 的架构不熟。
        3
    johnsonshu   76 天前
    @raysonx google 了,才发觉就是 tigervnc 的。 但是,我现在卡在了 systemctl --user enable x0vncserver 上了。
    Redhat 7 好像不能用 user mode systemd.
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3927 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 23ms · UTC 01:35 · PVG 09:35 · LAX 17:35 · JFK 20:35
    ♥ Do have faith in what you're doing.