V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
ryanlid
V2EX  ›  问与答

服务器系统版本升级的疑问

  •  
  •   ryanlid · 2020-12-23 10:29:50 +08:00 · 874 次点击
    这是一个创建于 518 天前的主题,其中的信息可能已经有所发展或是发生改变。

    服务器在阿里云上,运行的是 ubuntu 18.04 ,平时就 apt update,apt upgrade 升级一下软件。

    如果要升级到 20.04 ,是不是直接运行 do-release-upgrade 就可以升级了,还是说重新初始化一个镜像比较好?

    14 条回复    2020-12-23 13:57:38 +08:00
    Tink
        1
    Tink  
       2020-12-23 10:58:45 +08:00   ❤️ 1
    建议别动
    ripperdev
        2
    ripperdev  
       2020-12-23 11:09:12 +08:00
    生产环境?那最好别动
    自己玩想怎么来都可以
    ohao
        3
    ohao  
       2020-12-23 11:10:27 +08:00 via iPhone
    跨大版本升级,一升级就趴窝了

    我们是复制数据到新系统调试好
    原 IP 地址绑新机器就好了,解析不改,IP 不改
    monsterxx03
        4
    monsterxx03  
       2020-12-23 11:12:47 +08:00
    100%挂
    dzdh
        5
    dzdh  
       2020-12-23 11:17:14 +08:00
    多机 做镜像备份然后升级一台 灰度测试 没问题 制作镜像全线镜像同步
    dzdh
        6
    dzdh  
       2020-12-23 11:18:01 +08:00
    @monsterxx03 线上升级过 N 次没挂过一次。ubuntu php+nginx
    monsterxx03
        7
    monsterxx03  
       2020-12-23 11:32:41 +08:00
    @dzdh 武断了一点, nginx + php 不涉及太多 c extention 的确可能成功.
    直接 do-release-upgrade 挂一般都是因为依赖, 像 python 这种 18.04 -> 20.04 会从 3.6 升级到 3.8 就有不兼容的地方.
    甚至 openssl 的升级都能搞挂一批依赖.
    一般都是从新的镜像重新部署测试
    ryanlid
        8
    ryanlid  
    OP
       2020-12-23 13:39:00 +08:00
    我是自己的机子,跑了几个小程序,现在程序尽量都是用 docker 运行的,云主机系统的是 ubuntu 18.04

    我是想着,5 年的支持期,这已经用了 2 年了,反正都要升级的,如果能早一点跟着升级,或许会比较容易一点。

    如果是能像桌面系统升级可以自动完成,就升级了。

    如果重新初始化一个镜像,就需要复制数据,安装环境,比较麻烦,要不就再等 3 年
    ryanlid
        9
    ryanlid  
    OP
       2020-12-23 13:42:34 +08:00
    @Tink #1
    @ripperdev #2
    @ohao #3
    @monsterxx03 #4
    @dzdh #5
    ryanlid
        10
    ryanlid  
    OP
       2020-12-23 13:46:30 +08:00
    @Tink #1
    @ripperdev #2
    @ohao #3
    @monsterxx03 #4
    @dzdh #5

    是我自己的机子,跑了几个小程序,程序尽量都是用 docker 运行的

    我试一下备份了,直接升级看看
    natashahollyz
        11
    natashahollyz  
       2020-12-23 13:46:42 +08:00
    除非有必要,否则不升级,我就是这样的,还在用 centos6
    felixcode
        12
    felixcode  
       2020-12-23 13:46:46 +08:00 via Android
    @ryanlid
    如果业务不能断,数据不能丢,那就必须做备份高可用,或者新建虚拟机切换。

    ubuntu 这样的大版本升级风险肯定是不小的,你在这问会不会有问题,没人能回答的了你。
    ryanlid
        13
    ryanlid  
    OP
       2020-12-23 13:55:19 +08:00
    @felixcode #12
    是噢,如果需要保证业务不中断,是应该要切换
    ryanlid
        14
    ryanlid  
    OP
       2020-12-23 13:57:38 +08:00
    @natashahollyz #11

    是的,主要是登陆服务器时它老是提示 😆
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2960 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 13:11 · PVG 21:11 · LAX 06:11 · JFK 09:11
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.