V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
zzzzxl
V2EX  ›  Ruby on Rails

当我更换 mac m2 芯片 无法使用使用 mysql2 报错 symbol not found in flat namespace (_mysql_affected_rows)

  •  
  •   zzzzxl · 147 天前 · 1256 次点击
    这是一个创建于 147 天前的主题,其中的信息可能已经有所发展或是发生改变。

    Rails 版本 7.0.3

    MySQL 版本 5.7.29

    Ruby 版本 3.1.1

    Rvm 版本 1.29.12

    mysql2 版本 ~> 0.5

    我的项目正在尝试迁移 m2 芯片,当我尝试运行rails s时 出现了以下错误

    `require': dlopen(/Users/list/.rvm/rubies/ruby-3.1.1/lib/ruby/gems/3.1.0/gems/mysql2-0.5.4/lib/mysql2/mysql2.bundle, 0x0009): symbol not found in flat namespace (_mysql_affected_rows)
    

    我尝试过以下解决方案,都不能解决

    bundle config build.mysql2 "--with-ldflags=-L/usr/local/mysql/lib --with-cppflags=-I/usr/local/mysql/include"
    
     gem install mysql2 -v '0.5' -- --with-mysql-config=/usr/local/mysql/bin/mysql_config --with-ldflags="-L/usr/local/mysql/lib -L$(brew --prefix openssl)/lib" --with-cppflags=-I$(brew --prefix openssl)/include
    

    请问如何解决这个问题?

    2 条回复    2022-09-03 10:49:19 +08:00
    cxh116
        2
    cxh116  
       147 天前 via Android   ❤️ 1
    --with-ldflags=-L/usr/local/mysql/lib --with-cppflags=-I/usr/local/mysql/include"


    这里的目录不对,要你安装的 mysql 5.7 的头文件目录,你用 brew 安装完时应该有提示,或 brew info package_name 也可以看到。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   实用小工具   ·   318 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 42ms · UTC 19:38 · PVG 03:38 · LAX 11:38 · JFK 14:38
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.