V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
fsckzy
V2EX  ›  Linux

ubuntu18 如何升级到 openssh9.x, openssl3.x

  •  
  •   fsckzy · 9 天前 · 1340 次点击

    网上的资料我都找遍了,并不好使。 请大佬赐教。

    17 条回复    2022-11-25 15:47:19 +08:00
    airqj
        1
    airqj  
       9 天前
    自己编译
    kaiger
        2
    kaiger  
       9 天前
    sudo apt install openssh-server
    sudo apt install openssl
    zed1018
        3
    zed1018  
       9 天前
    @kaiger 不会可以不答,没有必要强答。ubuntu 18 repo 哪有 9.x 的版本

    如果 op 是为了安全修复,ubuntu 一般是在老版本上 backport 的,具体需要查 cve 。

    如果一定要 9.x 只能自己编译了
    kaiger
        4
    kaiger  
       9 天前
    @fsckzy

    抱歉,请忽略我的强答,它可能行不通。
    singerll
        5
    singerll  
       9 天前
    自己编译。实际上 apt 的最新版本已经修复了漏洞,但是版本号没有升级,应付不了安全扫描工具。
    billlee
        6
    billlee  
       9 天前   ❤️ 1
    典型的安全工具破坏安全性的场景
    adoal
        7
    adoal  
       9 天前 via iPhone   ❤️ 1
    不要在旧版本的系统里自行升级基础组件的大版本号。
    如果系统还在 LTS 期内,发行商会做好安全更新的,有时候甚至会 backport 。
    如果已经不在 LTS 期了,那应该规划迁移到新版本。
    自行做大版本更新,有两个问题,一是跟系统里其它程序的兼容性无法保证,二是你装完了在以后的使用过程中大概率不会随时关注自己安装的组件的安全更新,而发行版打包好的自有发行商关注。
    julyclyde
        8
    julyclyde  
       9 天前
    跨版本升级 openssl 一般不得好死
    注意 openssl 的兼容版本是指小数点后一位
    JohnBull
        9
    JohnBull  
       8 天前
    @julyclyde 是的。openssl 命令行的输出非常放飞自我,随意改来改去,搞不好旧脚本就踩雷。库函数对密钥的填充算法变更也给我们挖过坑
    julyclyde
        10
    julyclyde  
       8 天前
    @JohnBull 也很少有人去 parse 其输出吧?一般都是调 lib ,或者指定文件输入输出
    主要是跨版本的 lib 不兼容,比较要命
    Usaki
        11
    Usaki  
       8 天前
    直接 strings 命令改 openssh 的版本号
    pagxir
        12
    pagxir  
       8 天前 via Android
    可以手动下载 archive.ubuntu.com 的包然后手动安装,我试过 Ubuntu 18 可以安装 5.19 的 kernel 包。不过如果报依赖关系就只能试试 apt source 下载新版本号的源代码,然后编译,这个方法我试过在 Ubuntu 18 上安装 ccache 4.6
    julyclyde
        13
    julyclyde  
       8 天前
    @Usaki strings 不是提取吗?还能写入?
    JohnBull
        14
    JohnBull  
       8 天前
    @julyclyde 我两个都用,两边的坑都踩过
    Usaki
        15
    Usaki  
       8 天前
    @julyclyde 提取后用管道+sed 修改
    julyclyde
        16
    julyclyde  
       8 天前
    @Usaki 哦,那你新旧字符串需要一样长才行。而且存在匹配序号的问题

    让我想起了二十几年前 DOS 里面用 PCTOOLS 改
    libook
        17
    libook  
       7 天前
    不知道啥需求,虽然可以自己编译,但感觉对于 openssl 这种被很多软件包依赖的东西,直接升级为非官方支持的版本风险比较大,你看看能不能在容器里跑新版的 openssh 和 openssl 。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2154 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 51ms · UTC 01:33 · PVG 09:33 · LAX 17:33 · JFK 20:33
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.