V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Geekerstar  ›  全部回复第 1 页 / 共 11 页
回复总数  214
1  2  3  4  5  6  7  8  9  10 ... 11  
@hatw 应该是当时的活动,现在可能没了
@hatw 成都
2023.10 新版 26.39 -3500 ,送 2kjd 卡

https://imgur.com/vjfXMiR
牛逼
10 天前
回复了 aquatichunter 创建的主题 问与答 西数 SN850 的风评到底如何?
我 sn750 2020 年京东 1399 买的,上个月坏了,jd 由于无货可换,直接退了 90%
37 天前
回复了 iceWater10 创建的主题 生活 租房有遇到特别恶心的情侣合租吗?
@sraey 中原?
40 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 试过了,完全 OK ,感谢大佬开源的牛逼工具
41 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 大佬,解决了可以给我回复一下么?或者把打好的包发我邮箱,再次感谢
41 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 好的,感谢大佬
41 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 感谢大佬,对了我是用的 ubuntu ,不知道是不是和这个有关? [email protected]
41 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 这个就是完整的,如果您那边能打包成功,能不能把打包后的文件发我试试能不能安装呢?

Flask==3.0.0
scikit-learn==1.3.1
flasgger==0.9.7.1
pandas==2.1.4
matplotlib==3.8.2
statsmodels==0.14.1
PyWavelets==1.5.0
minio==7.2.2
openpyxl==3.1.2
41 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 好像是和 requirements.txt 里的内容有关,试了下只留下一些是可以打包成功的。但是全部放上去就会报上面的错。

Flask==3.0.0
scikit-learn==1.3.1
flasgger==0.9.7.1
pandas==2.1.4
matplotlib==3.8.2
statsmodels==0.14.1
PyWavelets==1.5.0
minio==7.2.2
openpyxl==3.1.2
41 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 安装依赖包成功,最后复制的时候又报错了,这个是因为什么原因呢?

[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/io/../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/linalg/../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/odr/../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/optimize/../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/optimize/_trlib/../../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/sparse/linalg/_dsolve/../../../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/sparse/linalg/_eigen/arpack/../../../../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/sparse/linalg/_isolve/../../../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/sparse/linalg/_propack/../../../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/spatial/../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
[ OK ]: 拷贝动态库 /usr/local/python_env/3.9.0/alfonstest/lib/python3.9/site-packages/scipy/special/../../scipy.libs/libgfortran-040039e1.so.5.0.0 -> /usr/local/python_env/system_lib/alfonstest/libgfortran-040039e1.so.5.0.0 成功!
Traceback (most recent call last):
File "build.py", line 513, in <module>
prompt=args.project,
File "build.py", line 91, in wrapper
res = func(*args, **kwargs)
File "build.py", line 409, in run
self.pack_library()
File "build.py", line 91, in wrapper
res = func(*args, **kwargs)
File "build.py", line 248, in pack_library
shutil.copyfile(src=src_file, dst=dst_file)
File "/usr/lib64/python2.7/shutil.py", line 82, in copyfile
with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: 'not'
42 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 好的,感谢,我晚上回家试试
42 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
我换了个虚拟机还是不行,是不是网络有问题呢?安装三方包报 403 ,三方包是下面这些:
Flask==3.0.0
scikit-learn==1.3.1
flasgger==0.9.7.1
pandas==2.1.4
matplotlib==3.8.2
statsmodels==0.14.1
PyWavelets==1.5.0
minio==7.2.2
openpyxl==3.1.2
@Alfons
42 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
@Alfons 好像没有哦,我是在服务器上运行的。我马上重新弄个干净的虚拟机再试试。感谢你的工具,很牛逼,希望能成功,我昨天搞了一天离线安装没搞好
42 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
安装三方依赖包的时候报错了,是因为这个地址 403 么?

+++++++++++++++++安装项目第三方依赖包+++++++++++++++++
[ OK ]: Execute cmd -> source /usr/local/python3/3.9.0/alfonstest/bin/activate && export LD_LIBRARY_PATH=/usr/local/python3/3.9.0/alfonstest/main/lib:$LD_LIBRARY_PATH && pip install --upgrade pip && pip install -r /packages/requirements.txt
Looking in indexes: https://pypi.tuna.tsinghua.edu.cn/simple
Collecting pip
ERROR: HTTP error 403 while getting https://pypi.tuna.tsinghua.edu.cn/packages/15/aa/3f4c7bcee2057a76562a5b33ecbd199be08cdb4443a02e26bd2c3cf6fc39/pip-23.3.2-py3-none-any.whl#sha256=5052d7889c1f9d05224cd41741acb7c5d6fa735ab34e339624a614eaaa7e7d76 (from https://pypi.tuna.tsinghua.edu.cn/simple/pip/) (requires-python:>=3.7)
ERROR: Could not install requirement pip from https://pypi.tuna.tsinghua.edu.cn/packages/15/aa/3f4c7bcee2057a76562a5b33ecbd199be08cdb4443a02e26bd2c3cf6fc39/pip-23.3.2-py3-none-any.whl#sha256=5052d7889c1f9d05224cd41741acb7c5d6fa735ab34e339624a614eaaa7e7d76 because of HTTP error 403 Client Error: Forbidden for url: https://pypi.tuna.tsinghua.edu.cn/packages/15/aa/3f4c7bcee2057a76562a5b33ecbd199be08cdb4443a02e26bd2c3cf6fc39/pip-23.3.2-py3-none-any.whl for URL https://pypi.tuna.tsinghua.edu.cn/packages/15/aa/3f4c7bcee2057a76562a5b33ecbd199be08cdb4443a02e26bd2c3cf6fc39/pip-23.3.2-py3-none-any.whl#sha256=5052d7889c1f9d05224cd41741acb7c5d6fa735ab34e339624a614eaaa7e7d76 (from https://pypi.tuna.tsinghua.edu.cn/simple/pip/) (requires-python:>=3.7)
WARNING: You are using pip version 20.2.3; however, version 23.3.2 is available.
You should consider upgrading via the '/usr/local/python3/3.9.0/alfonstest/bin/python3 -m pip install --upgrade pip' command.
Traceback (most recent call last):
File "build.py", line 513, in <module>
prompt=args.project,
File "build.py", line 91, in wrapper
res = func(*args, **kwargs)
File "build.py", line 406, in run
self.pip_install()
File "build.py", line 91, in wrapper
res = func(*args, **kwargs)
File "build.py", line 209, in pip_install
requirements=requirements_path))
File "build.py", line 71, in run_local_cmd
raise
TypeError: exceptions must be old-style classes or derived from BaseException, not NoneType
42 天前
回复了 Alfons 创建的主题 Python Python 虚拟环境 打包 py-all-in-one
太巧了,昨天正需要这个,今天就看到了
56 天前
回复了 carloszhou 创建的主题 程序员 向各位大佬求一个资源站开源源码
WordPress 的 ripro ,很多在用
56 天前
回复了 magese 创建的主题 Java 有实际使用 SpringWebFlux 的大佬分享下经验吗?
jetlinks 有用这个
1  2  3  4  5  6  7  8  9  10 ... 11  
关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   5320 人在线   最高记录 6543   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.5 · 30ms · UTC 09:14 · PVG 17:14 · LAX 01:14 · JFK 04:14
Developed with CodeLauncher
♥ Do have faith in what you're doing.