flowdesign

flowdesign

V2EX 第 554226 号会员,加入于 2021-08-24 16:40:46 +08:00
flowdesign 最近回复了
50 天前
回复了 Yancey 创建的主题 NAS 关于 Jellyfin Plex emby 服务端转码的疑惑
转码逻辑具体是啥样的?
以 emby 为例, 首先看你客户端的设置, 客户端能够直接播放就不解码, 如果播放不了就看 server 端的解码设置, 其次可以针对于用户设置是否允许该用户播放需要解码的视频, 如果你是开心版并且显卡支持, 可以设置显卡硬解码优先, 如果是非开心版那就只能 cpu 软解了
如果我内网访问,不想转码,只是想让他推个流,可以做到吗?怎么做
可以, emby 的客户端可以设置为 direct play 模式, 不做解码, 前提还是你的客户端能播放
如果我外放访问,上传宽带够,也不想转码,可以做到吗?怎么做
可以, 做法没区别
这几个服务除了浏览器外,客户端都需要是固定的吗,infuse ,kodi 以及他们自己的客户端
infuse 支持 emby, kodi 也有对应的 emby 插件, plex 不熟悉
下了蓝光原盘或者杜比视界视频,电视能力够都支持,怎么样能体验到最好画质?
BDMV 相对麻烦, emby 服务器端能识别刮削, 但是客户端播放我没成功, 但理论上也是可以的, 因为一切要看客户端是不是能放
DV 我只有单层的 H265, 客户端是安卓的 Kodi, 完全没问题, 前提是安装 mod 版的, 不然会把 DV 识别为普通的 HDR10
66 天前
回复了 flowdesign 创建的主题 SSL Let's Encrypt 的泛域名证书申请总是出错
@GoodRui 这个我看懂了啊,但事实上并不存在这个所谓的 dns record ,所以我才会觉得奇怪
域名是新的,DDNS 到我的公网 IP 之后,这个 IP 并没有发生变化,而且我也 dig 过记录没有异常的数据的

@majula 如果直接手工执行的话是需要我去提供这个 txt 记录,但因为是用脚本直接调用配置好的 DDNS API ,所以按照我现在解决问题后的判断,就是腾讯对于 2.0 版本的 DNSPOD API 做了修改,亦或者是 let‘s encrypt 不支持,但换了 aliyun 的 API token 以后就正常申请到了
66 天前
回复了 flowdesign 创建的主题 SSL Let's Encrypt 的泛域名证书申请总是出错
搞定了,换成阿里云的 token 就一切正常,大概率是腾讯那边在强制使用新的 3.0api ,老的 api token 会有问题
把对应的 log 贴出来看看,这么说是不知道问题在哪里的
@malash
dmesg | grep bond 的结果因为混杂了很多 vlan tag 的软件接口,去掉那些以后跟 wan 口有关的看起来正常
[email protected]:~# dmesg | grep bond
[ 18.209568] 8021q: adding VLAN 0 to HW filter on device bondwan
[ 18.336374] bondwan: (slave eth1): Enslaving as an active interface with an up link
[ 18.340263] device bondwan entered promiscuous mode
[ 18.422994] bondwan: (slave eth2): Enslaving as an active interface with an up link
我的路由是 J4125 安装了 PVE 宿主,OP 是 PVE 里面的一个虚拟机,给分配了 2G 内存,日常负载我看过很低,测速的时候也就是不到 50%的 cpu 占用

回头再按你的建议把 vlan tag 去掉再看看,但是为了实现 IPTV 任意网口使用,还是要想个办法把 vlan51 、85 都加上的...
@malash
dmesg | grep bond 的结果如下
[ 18.382320] 8021q: adding VLAN 0 to HW filter on device bondwan
[ 18.384502] br-IPTV51: port 4(bondwan.51) entered blocking state
[ 18.385421] br-IPTV51: port 4(bondwan.51) entered disabled state
[ 18.386689] device bondwan.51 entered promiscuous mode
[ 18.387423] device bondwan entered promiscuous mode
[ 18.438353] br-IPTV85: port 4(bondwan.85) entered blocking state
[ 18.439293] br-IPTV85: port 4(bondwan.85) entered disabled state
[ 18.440374] device bondwan.85 entered promiscuous mode
[ 18.572613] bondwan: (slave eth1): Enslaving as an active interface with an u p link
[ 18.573799] IPv6: ADDRCONF(NETDEV_CHANGE): bondwan: link becomes ready
[ 18.574914] br-IPTV51: port 4(bondwan.51) entered blocking state
[ 18.575883] br-IPTV51: port 4(bondwan.51) entered forwarding state
[ 18.579326] br-IPTV85: port 4(bondwan.85) entered blocking state
[ 18.580288] br-IPTV85: port 4(bondwan.85) entered forwarding state
[ 18.685858] bondwan: (slave eth2): Enslaving as an active interface with an u p link
[ 102.968787] device bondwan.51 left promiscuous mode
[ 102.969839] br-IPTV51: port 4(bondwan.51) entered disabled state
[ 103.020110] device bondwan.85 left promiscuous mode
[ 103.021104] device bondwan left promiscuous mode
[ 103.022287] br-IPTV85: port 4(bondwan.85) entered disabled state
[ 103.236200] 8021q: adding VLAN 0 to HW filter on device bondwan
[ 103.240105] br-IPTV51: port 4(bondwan.51) entered blocking state
[ 103.241799] br-IPTV51: port 4(bondwan.51) entered disabled state
[ 103.243575] device bondwan.51 entered promiscuous mode
[ 103.244972] device bondwan entered promiscuous mode
[ 103.246447] br-IPTV51: port 4(bondwan.51) entered blocking state

network config 是这样的

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option packet_steering '1'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option delegate '0'
option _orig_ifname 'eth0'
option _orig_bridge 'true'
option ifname 'eth0'
option ipaddr '192.168.1.111'

config interface 'vpn0'
option ifname 'tun0'
option proto 'none'

config interface 'docker'
option ifname 'docker0'
option proto 'none'
option auto '0'

config device
option type 'bridge'
option name 'docker0'

config interface 'ipsec_server'
option ifname 'ipsec0'
option device 'ipsec0'
option proto 'static'
option ipaddr '192.168.100.1'
option netmask '255.255.255.0'

config interface 'wan'
option proto 'pppoe'
option username '马赛克'
option password '马赛克'
option keepalive '5 5'
option mtu '1460'
option ipv6 '0'
option delegate '0'
option _orig_ifname 'bondwan'
option _orig_bridge 'false'
option metric '40'
option ifname 'bondwan'

config interface 'IPTV51'
option type 'bridge'
option proto 'none'
option ifname 'bondwan.51 eth0.51 eth1.51 eth2.51'
option auto '1'
option delegate '0'

config interface 'IPTV85'
option type 'bridge'
option proto 'none'
option ifname 'bondwan.85 eth0.85 eth1.85 eth2.85'
option auto '1'
option delegate '0'

有一些 OP 自己加的 IPSec, VPN 啥的接口, 我也懒得删就留着了, 主要用的就是 wan, lan, 外加为了 IPTV 加出来的一堆带 vlan tag 的接口, 反正我自己看 log 就是压根没看出什么不妥的地方... 我刚刚是重启了路由器以后重新加载 rc.local 增加的 bonding, 然后这个 bonding 拨号成功后我测速依然不出意料地只有 700 多 M, 再然后它就突然断线, 看了一眼 eth2 口不亮了, 我暂时没空研究, 拔掉网线现在暂时还有网络来回帖, 晚上不敢再折腾下去, 不然要被赶出家门


@swiftg 你这句话让我很伤心啊
@yujincheng08 刚刚又搜了一大圈, 看到一个帖子提到华为光猫固件没有对应的 bonding 内核的问题 <https://www.right.com.cn/forum/thread-4036246-1-1.html> , 今天回去继续研究一下看看, 如果真的是固件没有内核的话, 我要么放弃 bonding, 要么换光猫了
@lcy630409 环路风暴没解决, 依然找不到原因, 逐渐陷入绝望中...
@malash 看了光猫设置, 二 /三层口配置都勾选了, 然后桥接 wan 口也没有绑定任何的 lan 口
@yujincheng08 光猫不需要对聚合做额外设置吧, 我也似乎没找到哪里有设置的

P.S V2 账号设置里的屏蔽搜索引擎并没有用嘛, 放狗搜 8546 聚合, 我的帖子都要上热搜了...
@lcy630409 我也觉得是环路风暴了, 关键就是产生的原因是什么? 通过 luci 增加的 bonding 口和我通过 rc.local 增加的 bonding 口是两次操作的唯一区别, 通过 luci 来增加的会写入到 etc/network 里面, 但是 rc.local 的就不会, 对 OP 没那么深入的了解, 还要花点时间研究一下才行, OP 固件本身的原因我觉得不太大, bonding 本身需要的插件也都是需要手工安装的
@malash 多谢提醒, 没记错之前我把桥接 wan 口绑定了所有的 lan 口, 回头去解绑了试试看
@yujincheng08 必须啊, 除非我被各处传播的信息给骗了, 我获取的信息特别指明华为带 Q 的光猫路由器都支持 balance rr 模式的, 8546Q 属于性价比比较高的一款
@lcy630409 多谢辛苦帮我录屏, 我刚刚又捣鼓了一阵, 并没有什么特殊操作, 然后突然就可以用 wan 口绑定新增加的这个 bond 口来 pppoe 拨号了, 然而坑爹的事情在于, 这种拨号测速直接变成了只有 20M...而且 ifconfig 看到 eth1 和 eth2 口的数据流量都是被放大无数倍, 我重启路由然后就打开测速网页测两次, wan 口显示流量大概是几百兆, eth1 和 eth2 都是已经到了 10G+的状态, 为了家庭和谐, 先暂时改成了单线单拨, 回头再仔细研究一下到底问题是什么...

@swiftg 你的这个设置跟我之前曾经尝试的是一样的, 我唯一没做的就是指定 mac 地址, 但按理说这个不影响测速才对, 感觉还是没有找到主因是什么
关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1189 人在线   最高记录 5497   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.5 · 27ms · UTC 20:38 · PVG 04:38 · LAX 12:38 · JFK 15:38
Developed with CodeLauncher
♥ Do have faith in what you're doing.