首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python 学习手册
Python Cookbook
Python 基础教程
Python Sites
PyPI - Python Package Index
http://www.simple-is-better.com/
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
leeeeee
V2EX  ›  Python

请问一下现在新开 Python 项目都用第三版了吧?

  •  
  •   leeeeee · 2018-08-19 11:11:29 +08:00 · 2304 次点击
    这是一个创建于 524 天前的主题,其中的信息可能已经有所发展或是发生改变。
    新开 Python 爬虫项目,想请教一下,现在都用最新版( 3.7 )了吧?常用的库都有了吧?
    谢谢。
    14 回复  |  直到 2018-08-29 03:19:40 +08:00
    lihongjie0209
        1
    lihongjie0209   2018-08-19 11:53:31 +08:00
    centos 自带什么用什么, 我不做爬虫
    ericls
        2
    ericls   2018-08-19 11:59:04 +08:00 via iPhone
    几年没写过 Python 2 了
    HelloAmadeus
        3
    HelloAmadeus   2018-08-19 12:05:00 +08:00 via Android
    最近有个重构项目,用了 f-string 的语法,版本限制在了 3.6 以上,3.7 刚出的时候看了一眼,有些库的 setup 是写死了 Python 支持的版本库的,所以还不能支持 3.7,所以并没有用 dataclass
    huangzhe8263
        4
    huangzhe8263   2018-08-19 12:07:57 +08:00 via Android
    并不,连不了外网,centos 最高 2.7.5😂
    kunluanbudang
        5
    kunluanbudang   2018-08-19 12:08:37 +08:00 via Android
    3.6 标配了,

    公司项目也是 3.6 了
    f2f2f
        6
    f2f2f   2018-08-19 12:15:53 +08:00
    centos 7 自带 2.7 +1
    qq976739120
        7
    qq976739120   2018-08-19 12:18:58 +08:00
    完全独立的新开项目可以选 3 以上,不然基本还是 2.7
    prolic
        8
    prolic   2018-08-19 14:48:04 +08:00 via Android
    用 3 吧,第三方库很全了,docker 和 pyenv 等等的 Python 版本管理方案也比较成熟了
    Kilerd
        9
    Kilerd   2018-08-19 19:44:30 +08:00
    没有,Python3 现在简直荒无人烟,建议使用 Python 2,还是用 urllib 写舒服,自由可控。
    siteshen
        10
    siteshen   2018-08-20 09:38:15 +08:00
    我厂之前简单调研过,python3 绝大部分场景够用,三年前的新项目就在用了。
    Cu635
        11
    Cu635   2018-08-22 13:17:01 +08:00
    @lihongjie0209
    centos 自带的也有 py3 了吧,不过是 3.4 还是 3.2 的老 py3 而已。
    lihongjie0209
        12
    lihongjie0209   2018-08-22 14:35:47 +08:00
    @Cu635 #11 哪个版本?
    ksharp8
        13
    ksharp8   2018-08-24 09:10:07 +08:00
    两个一起装,env 切换
    Cu635
        14
    Cu635   2018-08-29 03:19:40 +08:00
    @lihongjie0209
    7.x,时间有点长我忘了是 x 是几了。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2109 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 28ms · UTC 12:32 · PVG 20:32 · LAX 04:32 · JFK 07:32
    ♥ Do have faith in what you're doing.