首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  macOS

macOS 现在已经不能再安装 Tampermonkey 了,已经安装过的且用且珍惜吧

  •  1
     
  •   f1ynnv2 · 42 天前 · 7305 次点击
    这是一个创建于 42 天前的主题,其中的信息可能已经有所发展或是发生改变。
    刚刚新装了一台 Macmini,想装 Tampermonkey,其官网的所谓下载链接,其实是直接跳转到苹果的 safari extension gallery 网址,但是苹果的这个页面是直接调用本机的 App Store。结果,App Store 里其实根本找不到 Tampermonkey。

    app store 账号试了中区和美区,都没有 Tampermonkey。

    新的 macmini 是 10.14.6,以及之前装过 Tampermonkey 的一台 mba 现在也无法更新 Tampermonkey。据说以后 safari 13 里也不让用了。难道是现在提前下手了?
    第 1 条附言  ·  41 天前
    准确的说应该是 macOS 下的 Safari 不能安装 Tampermonkey 了,不知道怎么改标题,就直接附言里说明一下吧,不好意思引起困扰。
    43 回复  |  直到 2019-09-10 00:18:39 +08:00
        1
    czwstc   42 天前   ♥ 1
    switch to Chrome ?
        2
    ShadyK   42 天前 via iPad
    我记得前段时间我恢复系统也是卡在 extension gallery 找不到 tampermonkey 的页面,后来怎么弄的忘记了,但最后还是装上了
        3
    f1ynnv2   42 天前
    @czwstc 目前看来只能如此了,只是 safari 用习惯了,另外 mba 用起来感觉 safari 确实比 chrome 省电。
        4
    worldGM   42 天前 via iPhone
    用 firefoxb
        5
    blaaibla   42 天前   ♥ 1
    對啊,我也是很不喜歡 safari 這一點的調整。發覺為了安全,靈活使用工具的空間都沒有了,用戶的自由越來越少。
        6
    worldGM   42 天前 via iPhone
    @worldGM firefox 吧
        7
    CEBBCAT   42 天前 via Android   ♥ 8
    safari ?那不是用来查 Homwbrew 安装指令的吗?然后 brew cask install google-chrome
        8
    f1ynnv2   42 天前
    @ShadyK 大神赶紧回想下,造福众生
        9
    keyv   42 天前 via iPhone
    我之前也是在那个网页那加载不出来,后来好像挂代理就好了
        10
    keyv   42 天前 via iPhone
    @keyv #9 刚刚试了一下。发现现在的情况之前完全不一样了😂
        11
    LoveCnElvis   42 天前
    我前天刚装了,运气真好。。
        12
    liangch   42 天前
    10.15 是不能用了。10.14 还能。
        13
    chinvo   42 天前 via iPhone
    10.15 safari 只能用 app 带的插件,以前装好的也会自动删除
        14
    heapfun   42 天前 via iPhone
    不装 10.15 就不能装 xcode11,不装 xcode11 就用不了 swiftui,慌的一批
        15
    xjbeta   42 天前
    卸载了试了一下 确实没了 没了.....
        16
    zhuangku556   42 天前
    10.14 我是直接下的离线安装包
        17
    damngood   42 天前 via iPhone
    @heapfun xcode 11 不需要 10.15
    swift ui 更好的支持倒是需要
        18
    damngood   42 天前 via iPhone
    只用 Safari. 对插件依赖不严重的话在 mac 上 Safari 是各方面都做的不错的选择了
        19
    shoujiaxin   42 天前
    10.14.5 之前安装过,但是刚才看了一下突然发现已经没了,估计是被卸载了,另外一个非 Store 安装的插件也没了
        20
    tslling   42 天前 via Android
    标题不准确,建议把 macos 改为 safari
        21
    wuhanchu   42 天前 via iPhone
    safari 现在很多插件装不上了
        22
    glaucus   42 天前 via iPhone
    建议把标题的 macOS 改成 Safari,我用的好好的被你标题整蒙了
        23
    caomu   42 天前 via Android
    chrome 也打算收紧全选,还是转投我大 firefox 吧。
        24
    caomu   42 天前 via Android
    chrome 也打算收紧权限,还是转投我大 firefox 吧。
        25
    1608637229   42 天前
    @caomu chrome 要是不让装我果断转火狐。目前火狐仍是我的备用浏览器
        26
    snorlax   42 天前
    歪个楼,希望 Chrome 上能安装 Tree Style Tab
        27
    GarethChu   42 天前
    chrome 不影响的吧,一般都用 chrome
        28
    CEBBCAT   42 天前
    @caomu #24 尝试转过两次,都失败了,觉得还是 Chrome 完成度高一些。
        29
    shuangyeying   42 天前
    Safari 的屏蔽广告插件早就没了,也是很久不用 Safari 了。
        30
    zhuangku556   42 天前
    @shuangyeying 用 adguard
        31
    NG6   42 天前 via iPhone
    试试这个
    https://sleele.com/2018/11/30/macbook 更新到 10-14mojave 后 safari 插件小时,不能安装插件 /
        32
    lbalaba   42 天前
    去年这个时候也是这个情况 有没有可能过几个版本就适配上了 或者找到替代方法了呢
        33
    fatelight   41 天前
    当然 chrome 啦
        34
    efsg   41 天前 via Android
    准备转投 FX 了
        35
    f1ynnv2   41 天前
    @xjbeta 你这个操作 666 啊,以身试险
        36
    f1ynnv2   41 天前
    @tslling 有道理,可是好像不能修改标题?只能附加内容。。。
        37
    alphatoad   41 天前 via iPhone
    Firefox 唯一的问题就是糟糕的手机版和书签管理
    要不然真的很完美
        38
    lovestudykid   41 天前
    我记得可以 developer mode 安装吧,以前装过没上架的插件,不知道现在可不可以
        39
    fvckDaybyte2   41 天前
    @heapfun 不装 10.15 为何不能装 xcode11,直接 app store 更新到 xcode11 不就好了?
        40
    forelegance   41 天前 via iPhone
    Stylus 也不能用了
        41
    fvckDaybyte2   41 天前
    找到个替代品,开源的,直接 xcode build 完就能用,不知道是否能代替:
    https://github.com/quoid/userscripts
        42
    tanranran   40 天前
    @fvckDaybyte2 #39 更新 Xcode11 最低要求系统是 10.15
        43
    fvckDaybyte2   40 天前
    @tanranran ……你直接在 10.14 上就能运行 xcode 11 beta 7 了,正式版也不会要求 10.15 ,以前最新 xcode 也没有要求最新系统。

    Google 一下就能知道:
    Xcode 11 requires a Mac running macOS Mojave 10.14.4 or later.
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2433 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 28ms · UTC 14:01 · PVG 22:01 · LAX 07:01 · JFK 10:01
    ♥ Do have faith in what you're doing.