首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  前端开发

有没有做 zf 项目的前端大佬?

  •  
  •   wyz123723 · 159 天前 · 2948 次点击
    这是一个创建于 159 天前的主题,其中的信息可能已经有所发展或是发生改变。
    面了一家作 zf 项目的公司,对方可能有意向要我。之前没做过 zf 项目想来咨询一些问题。
    zf 现在一般在用什么浏览器版本?
    现在还需要可以考虑兼容性问题吗?
    框架的选择自由吗?用最新版的 React 的全家桶是可行的吗?
    具体的开发体验如何?
    35 回复  |  直到 2019-06-09 05:25:30 +08:00
        1
    wyz123723   159 天前
    补充一下,因为是初创公司,什么都需要从 0 开始,没有具体的参考,所以特来请教过来人
        2
    araaaa   159 天前   ♥ 1
    ie8, chrome43, 得考虑兼容 ie, 断网开发
        3
    araaaa   159 天前
    我现在是驻场所以断网
        4
    guojxx   159 天前
    需要兼容 IE,少想一些花哨的东西,需求响应要快,问题要少
        5
    coolair   159 天前 via Android
    初创公司可能自由度比较高,我原来在某大型企业,专做政务项目,现在基本不考虑 IE,网站直接推荐使用 Chrome,不过主流浏览器兼容性还是要考虑。
    一般不做前后端分离,如果涉及到省市县各级部署,实施人员不懂研发,这个调试代价太大,一般都是 java 打包上中间件。
    看了下老东家的产品,目前基本上是 bootstrap 加 jquery 一把梭。
    另外,老东家的图标字体都是自己画的,不用第三方。
        6
    wyz123723   159 天前
    @araaaa 请问用的是什么技术栈?
        7
    YuxiangLuo   159 天前 via Android
    面向 windows XP 编程
        8
    Nikoyang   159 天前
    Chrome,easyUI 足够
        9
    Yiki   159 天前
    那就是拿 IE67891011 把你恶心一遍了。。。
        10
    hyy1995   159 天前
    zf 项目?难道不是 jquery 一把梭
        11
    yahon   159 天前
    看是什么项目吧 反正我们这都是兼容 Chrome 最新版 随便耍
        12
    66beta   159 天前 via Android
    react ? jquery 都得用 1.0 版本
        13
    nosky   159 天前 via Android
    我同学公司做的一个 zf 项目,过去实施的时候说界面太丑了,然后对面某官员拍脑袋想了一个。。。笑死我了
        14
    Sapp   159 天前
    我怀疑楼上真的做过吗?我这公司全都是 zf 项目,没有一个要兼容 ie 的,都是只做 chrome,其他浏览器一律弹提示。没有一个客户有意见,只是公安部有一次要求兼容 ie6,最后被商务解决了。开发就是普通公司开发,最后让运维当地去部署就行了
        15
    Sapp   159 天前   ♥ 1
    事实上只要商务够叼,兼容个锤子? 个别项目就给套一层 electron 当客户端卖就行了。
        16
    gimp   159 天前
    可以用支持 XP 系统的最后一个 Chrome 版本做开发,用户系统可以为他们安装 Chrome
        17
    emmmbu   159 天前
    弱弱的问 zf 是什么 后端表示没听说过
        18
    orzorzorzorz   159 天前
    上面不需要兼容的真是幸福,浙江这块的 zf 是真的难啃,基本都是要兼容 ie,不然就不给标。
    之前我还对着某厂视频插件落发,这玩意只能在 ie 上跑,不能在 chrome 上调试。
    不过说回来,还是看要兼容到 ie 几,ie11 而且合同没要求,那用现代的库是太大问题的,撑死 polyfill 下完事。如果是往下的,那就免不了往 jQuery 上走。
    至于开发体验,抱歉,没有体验,别想着玩花了,多用 ifame 保平安...
        19
    Umenezumi   159 天前
    @emmmbu #17 公家的项目
        20
    kibess   159 天前
    要求只做 chrome 如果不是 chrome 直接不让进,具体技术框架看具体要求
        21
    supuwoerc   159 天前 via iPhone
    我就是,合作单位从工信部农业部国安局到地方党校🐶虽然项目贼大,但是干的活还是和别的公司差不多
        22
    supuwoerc   159 天前 via iPhone
    最近在做的项目需要兼容 ie、360,谷歌,火狐,项目从之前的前后端不分离逐渐重构成分离的了,技术啥都有,主要 vue framework7 等等,技术选型和我们没啥关系,我们都是干活的🐶不会就看文档🐶最近就在看钉钉小程序的文档🐶发现和微信一样🐶于是划水来回贴
        23
    undermoodzyx   159 天前
    看来走运了,做了一个不用兼容的 zf 项目,各种 es6 骚操作完全不用考虑兼容,就是这个 feel,爽
        24
    virus94   159 天前
    同事上一家是做 zf 项目的,24 小时响应,随叫随到.坐标上海张江
        25
    theNike   159 天前
    直接用 chrome 套壳,将浏览器和各种外部插件整合一成个包,配合自动更新插件,强行把网站当成应用程序来用,还真别说,用户体验还挺不错(对 zf 单位来说)。
        26
    hideonwhere   159 天前
    @Sapp 你是不知道对接客户的是舔狗有多少难受,客户说什么就什么 完全不考虑开发感受
        27
    tilv37   159 天前
    chrome 和 IE 都存在,部分功能需要使用 ActiveX 控件,所以非 IE 不可。
    需要考虑浏览器兼容。
    然后如果是驻场,有可能没有外网使用
        28
    newmind   159 天前 via Android
    zf 项目? easyui 了解下,jquery 一把梭,兼容 IE8
        29
    gaoryrt   159 天前
    好奇哪个 api 算是分界线呢?
    fetch 还是 promise
    web component 还是 wasm 呢
        30
    wemore   159 天前
    最低 ie11 用的 jq,毕竟用户电脑好多是 win10 的。额。。。我们这个也算 zf 项目吧,二三线城市,不过成立来说比较晚
        31
    wemore   159 天前
    @wemore 有个问题就是浏览器用的比较混杂,谷歌,ie,edge,360,火狐都有人用,搞的我一个后端写前端老阔疼。
        32
    emric   159 天前 via iPhone
    一般 ie9+ 比较基层 ie8+ 我推公司用上了京东的前端技术栈,编译 es3、css 布丁
    还算不太头疼,比当初在某游戏公司活动页兼容 ie6 好多了…
        33
    857681664   158 天前 via Android
    前东家做的 zf 项目,前端从 ng 到 vue 都有
        34
    sheldom   157 天前
    今年开始应该提的 Firefox 吧。。毕竟国产系统都是自带 Firefox
        35
    legendlee   156 天前 via Android
    如果是新项目,不要考虑兼容 ie,浏览器收敛是实施的一部分,不要让开发埋单。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   946 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 28ms · UTC 20:42 · PVG 04:42 · LAX 12:42 · JFK 15:42
    ♥ Do have faith in what you're doing.